Back to overview
Downtime

Server is down

Sep 02 at 12:33am AEST
Affected services
Server

Resolved
Sep 02 at 04:57am AEST

Service Restored
The DNS resolution issue has been fully resolved and all systems are now operating normally. The MLD iOS app and web app are back online, and all features including trip management, runsheets, invoices, and account actions are working again. Thank you for your patience while we addressed the issue.

Created
Sep 02 at 12:33am AEST

Service Disruption: DNS Resolution Issue
We are currently experiencing a DNS resolution issue that is affecting our servers. As a result, the MLD iOS app and web app are unavailable. You will be unable to manage trips, view runsheets or invoices, or create or deactivate your account during this period. Our team is working to restore full service as quickly as possible. We apologize for the inconvenience.